解决GVM中安装go1.9 Compile失败问题

用gvm安装go 1.9老失败,出现如下提示

➜ ~ gvm install go1.9
Updating Go source…
Installing go1.9…
* Compiling…
ERROR: Failed to compile. Check the logs at /Users/monk/.gvm/logs/go-go1.9-compile.log
ERROR: Failed to use installed version

后来在Github找到了解决方法,就是在安装前执行

export GOROOT_BOOTSTRAP=$GOROOT

如果GOROOT_BOOTSTRAP没有设置,默认值是$HOME/go, 在当时的环境下这个值是不对的。

Tags:

categories IT

没有评论

No comments yet.

RSS feed for comments on this post. TrackBack URI

Leave a comment

  • :em48:
  • :em32:
  • :em34:
  • :em14:
  • :em72:
  • :em37:
  • :em53:
  • :em56:
  • :em25:
  • :em39:
  • :em04:
  • :em13:
  • :em38:
  • :em20:
  • :em41:
  • :em31:
  • :em16:
  • :em45:
  • :em21:
  • :em43:
  • :em12:
  • :em71:
  • :em11:
  • :em23:
  • :em46:
  • :em66:
  • :em47:
  • :em02:
  • :em49:
  • :em54:
  • :em27:
  • :em36:
  • :em35:
  • :em15:
  • :em05:
  • :em26:
  • :em44:
  • :em06:
  • :em64:
  • :em01:
  • :em55:
  • :em70:
  • :em28:
  • :em40:
  • :em67:
  • :em18:
  • :em63:
  • :em09:
  • :em10:
  • :em62:
  • :em69:
  • :em03:
  • :em08:
  • :em33:
  • :em42:
  • :em52:
  • :em51:
  • :em68:
  • :em30:
  • :em65:
  • :em59:
  • :em29:
  • :em07:
  • :em50:
  • :em17:
  • :em24:
  • :em57:
  • :em22:
  • :em19:
  • :em60:
  • :em61:
  • :em58: